<!doctype html>

<!--[if IE 7 ]><html class="no-js ie7" lang="en"><![endif]-->
<!--[if IE 8 ]><html class="no-js ie8" lang="en"><![endif]-->
<!--[if IE 9 ]><html class="no-js ie9" lang="en"><![endif]-->
<!--[if gt IE 9]><!--><html class="no-js" lang="de"><!--<![endif]-->

<head>

<meta charset="utf-8">

<title>The State of CRLs Today</title>

<meta name="description" content="CRLs are not an exciting technology, but they&#x27;re still used by the Web PKI. It appears some CAs don&#x27;t think they need to keep them online. Shame.">
<meta name="viewport" content="width=device-width, initial-scale=1.0">

<!--[if IE]>
<meta http-equiv="imagetoolbar" content="no">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<![endif]-->

<!-- CSS -->

<link href='//fonts.googleapis.com/css?family=Raleway:200' rel='stylesheet' type='text/css'>
<link href='//fonts.googleapis.com/css?family=Open+Sans:300' rel='stylesheet' type='text/css'>

<link rel="stylesheet" href="/assets/css/base.css?v=e1bc17359f">
<link rel="stylesheet" href="/assets/css/style.css?v=e1bc17359f">
<link rel="stylesheet" href="/assets/css/font-awesome.min.css?v=e1bc17359f">
<link rel="stylesheet" href="/assets/css/prism.css?v=e1bc17359f">

<!-- Modernizr -->
<script src="/assets/js/libs/modernizr.js?v=e1bc17359f"></script>

<!-- Icons -->

<link rel="shortcut icon" href="/assets/images/favicon.ico">

<!-- For iPad with high-resolution Retina display running iOS ≥ 7: -->
<link rel="apple-touch-icon" sizes="152x152" href="/assets/images/apple-touch-icon-152x152.png">
<!-- For iPad with high-resolution Retina display running iOS ≤ 6: -->
<link rel="apple-touch-icon" sizes="144x144" href="/assets/images/apple-touch-icon-144x144.png">
<!-- For iPhone with high-resolution Retina display running iOS ≥ 7: -->
<link rel="apple-touch-icon" sizes="120x120" href="/assets/images/apple-touch-icon-120x120.png">
<!-- For iPhone with high-resolution Retina display running iOS ≤ 6: -->
<link rel="apple-touch-icon" sizes="114x114" href="/assets/images/apple-touch-icon-114x114.png">
<!-- For the iPad mini and the first- and second-generation iPad on iOS ≥ 7: -->
<link rel="apple-touch-icon" sizes="76x76" href="/assets/images/apple-touch-icon-76x76.png">
<!-- For the iPad mini and the first- and second-generation iPad on iOS ≤ 6: -->
<link rel="apple-touch-icon" sizes="72x72" href="/assets/images/apple-touch-icon-72x72.png">
<!-- For non-Retina iPhone, iPod Touch, and Android 2.1+ devices: -->
<link rel="apple-touch-icon" sizes="57x57" href="/assets/images/apple-touch-icon-57x57.png">

<!-- RSS -->

<link rel="canonical" href="https://tacticalsecret.com/the-state-of-crls/" />
    <meta name="referrer" content="no-referrer-when-downgrade" />
    <link rel="amphtml" href="https://tacticalsecret.com/the-state-of-crls/amp/" />
    
    <meta property="og:site_name" content="The Internet of Secure Things" />
    <meta property="og:type" content="article" />
    <meta property="og:title" content="The State of CRLs Today" />
    <meta property="og:description" content="CRLs are not an exciting technology, but they&#x27;re still used by the Web PKI. It appears some CAs don&#x27;t think they need to keep them online. Shame." />
    <meta property="og:url" content="https://tacticalsecret.com/the-state-of-crls/" />
    <meta property="article:published_time" content="2017-08-18T21:41:07.000Z" />
    <meta property="article:modified_time" content="2017-08-18T21:50:22.000Z" />
    <meta property="article:tag" content="PKI" />
    <meta property="article:tag" content="mozilla" />
    <meta property="article:tag" content="charts" />
    
    <meta name="twitter:card" content="summary" />
    <meta name="twitter:title" content="The State of CRLs Today" />
    <meta name="twitter:description" content="CRLs are not an exciting technology, but they&#x27;re still used by the Web PKI. It appears some CAs don&#x27;t think they need to keep them online. Shame." />
    <meta name="twitter:url" content="https://tacticalsecret.com/the-state-of-crls/" />
    <meta name="twitter:label1" content="Written by" />
    <meta name="twitter:data1" content="J.C. Jones" />
    <meta name="twitter:label2" content="Filed under" />
    <meta name="twitter:data2" content="PKI, mozilla, charts" />
    
    <script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "Article",
    "publisher": {
        "@type": "Organization",
        "name": "The Internet of Secure Things",
        "logo": "https://tacticalsecret.com/content/images/2014/Aug/jc_small_headshot-round.png"
    },
    "author": {
        "@type": "Person",
        "name": "J.C. Jones",
        "image": {
            "@type": "ImageObject",
            "url": "https://tacticalsecret.com/content/images/2014/Aug/jc_small_headshot.jpg",
            "width": 256,
            "height": 294
        },
        "url": "https://tacticalsecret.com/author/jc-jones/",
        "sameAs": [
            "https://twitter.com/jamespugjones"
        ],
        "description": "Security and distributed computing nerd on an adventure to protect and connect the Internet of Things."
    },
    "headline": "The State of CRLs Today",
    "url": "https://tacticalsecret.com/the-state-of-crls/",
    "datePublished": "2017-08-18T21:41:07.000Z",
    "dateModified": "2017-08-18T21:50:22.000Z",
    "keywords": "PKI, mozilla, charts",
    "description": "CRLs are not an exciting technology, but they&#x27;re still used by the Web PKI. It appears some CAs don&#x27;t think they need to keep them online. Shame.",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://tacticalsecret.com"
    }
}
    </script>

    <meta name="generator" content="Ghost 0.11" />
    <link rel="alternate" type="application/rss+xml" title="The Internet of Secure Things" href="https://tacticalsecret.com/rss/" />
    <link rel="stylesheet" href="/css/overrides.css">

</head>

<body class="post-template tag-pki-2 tag-mozilla tag-charts">
<!--- TEMPLATE FOR BLOG POST --->

<div class="container">
	
	<!-- HEADER COLUMN --->	
	<div class="header-col">
		<header>
			<!--- HEADER TEMPLATE FILE --->

<!--- HEADER PLACE HOLDER - to occupy width for fixed left column  --->
<div class="header-placeholder">&nbsp;</div>

<!--- CONTNET OF HEADER --->
<div class="header-content" style="background-image: url('/content/images/2014/Aug/blog-banner-vert-2-5.jpg')">
	
		<a class="logo" href="https://tacticalsecret.com"><img src="/content/images/2014/Aug/jc_small_headshot-round.png" alt="Blog Logo" class="blog-logo" /></a>

	<!--- Title --->	
	<div class="header-title">

		<a href="https://tacticalsecret.com">
			<h1 class="blog-title">The Internet of Secure Things</h1>
		</a>
		<h2 class="blog-description">On a mission to solve information security issues for the whole Internet. That, and whatever else comes up.</h2>
	</div>

	<!--- Header Menu --->
	<!--- MENU SECTION --->

<div class="header-menu">
	<!--- HOME BUTTON --->
	<a href="https://tacticalsecret.com" title="Home">
		<div class="header-menu-button">
			<span class="header-menu-button-label">
				HOME
			</span>
			<span class="fa-stack header-menu-button-icon">
				<i class="fa fa-square-o fa-stack-2x"></i>
				<i class="fa fa-home fa-stack-1x"></i>
			</span>
		</div>
	</a>
	
	<!--- ABOUT BUTTON --->
	<!--- Link to a static page titled "About" --->
	<a href="https://tacticalsecret.com/about/" title="About">
		<div class="header-menu-button">
			<span class="header-menu-button-label">
				ABOUT
			</span>
			<span class="fa-stack header-menu-button-icon">
				<i class="fa fa-square-o fa-stack-2x"></i>
				<i class="fa fa-user fa-stack-1x"></i>
			</span>
		</div>
	</a>
	
	<!--- RSS BUTTON --->
	<a href="https://tacticalsecret.com/rss" title="Subscribe">
		<div class="header-menu-button">
			<span class="header-menu-button-label">
				RSS
			</span>
			<span class="fa-stack header-menu-button-icon">
				<i class="fa fa-square-o fa-stack-2x"></i>
				<i class="fa fa-rss fa-stack-1x"></i>
			</span>
		</div>
	</a>

	<!--- Twitter BUTTON --->
	<a href="https://twitter.com/jamespugjones" title="Twitter">
		<div class="header-menu-button">
			<span class="header-menu-button-label">
				Twitter
			</span>
			<span class="fa-stack header-menu-button-icon">
				<i class="fa fa-square-o fa-stack-2x"></i>
				<i class="fa fa-twitter fa-stack-1x"></i>
			</span>
		</div>
	</a>

	

</div>

</div>

		</header>
	</div>
	
	
	<!--- MAIN COLUMN --->
	<div class="main-col">
		<main>
			<div class="post-entry">
				<!--- POST CONTENT --->
				<article role="article" itemscope itemtype="http://schema.org/Article" class="postlistArticle">
					<h1 class="post-title">The State of CRLs Today</h1>
					<time datetime="2017 Aug 18" itemprop="datePublished">
						<span class="datetime-full">2017.08.18</span>
					</time>
					<div class="post-info">
							<div class="tags">
							<i class="fa fa-tags fa-lg"></i> <a href="/tag/pki-2/">PKI</a> | <a href="/tag/mozilla/">mozilla</a> | <a href="/tag/charts/">charts</a>
							</div>
					</div>
					<div class="hrule"></div>
					<div class="postContent">
						<p>Certificate Revocation Lists (CRLs) are a way for Certificate Authorities to announce to their relying parties (e.g., users validating the certificates) that a Certificate they issued should no longer be trusted. E.g., was revoked.</p>

<p>As the name implies, they're just flat lists of revoked certificates. This has advantages and disadvantages:</p>

<p>Advantages:</p>

<ul>
<li>It's easy to see how many revocations there are</li>
<li>It's easy to see differences from day to day</li>
<li>Since processing the list is up to the client, it doesn't reveal what information you're interested in</li>
</ul>

<p>Disadvantages:</p>

<ul>
<li>They can quickly get quite big, leading to significant latency while downloading a web page</li>
<li>They're not particularly compressible</li>
<li>There's information in there you probably will never care about</li>
</ul>

<p>CRLs aren't much used anymore; Firefox stopped checking them in version 28 in 2014, in favor of <a href="https://en.wikipedia.org/wiki/Online_Certificate_Status_Protocol">online status checks (OCSP)</a>.</p>

<p>The <a href="https://github.com/cabforum/documents#overview">Baseline Requirements</a> nevertheless still require that CRLs, if published, remain available:</p>

<blockquote>
  <h3 id="4102serviceavailability">4.10.2 Service availability</h3>
  
  <p>The CA SHALL operate and maintain its CRL and OCSP capability with resources sufficient to provide a response time of ten seconds or less under normal operating conditions.</p>
</blockquote>

<p>Since much as been written about the <a href="http://uptime.netcraft.com/perf/reports/performance/OCSP">availability of OCSP</a>, I thought I'd check-in on CRLs.</p>

<h2 id="collectingavailablecrls">Collecting available CRLs</h2>

<p>When a certificate's status will be available in a CRL, that's encoded into the certificate itself (RFC 5280, 4.2.1.13). If that field is there, we should expect the CRL to survive for the lifetime of the certificate.</p>

<p>I went to <a href="https://censys.io/">Censys.io</a> and after a quick request to them for SQL access, I ran this query:  </p>

<pre><code class="language-sql">SELECT parsed.extensions.crl_distribution_points  
   FROM certificates.certificates
WHERE validation.nss.valid = true  
   AND parsed.extensions.crl_distribution_points LIKE 'http%' 
   AND parsed.validity.end &gt;= '2017-07-18 00:00'
GROUP BY parsed.extensions.crl_distribution_points  
</code></pre>

<p>Today, this yields <a href="https://gist.github.com/jcjones/92fe0297f950ba2748454b5ee8021b5b#file-all_crls-csv">3,035 CRLs, the list of which I've posted on Github</a>.</p>

<p>Downloading those CRLs into a directory <code>downloaded_crls</code> can be done serially using <code>wget</code> quite simply, logging to a file named <code>wget_log-all_crls.txt</code>:  </p>

<pre><code class="language-sh">mkdir downloaded_crls  
script wget_log-all_crls.txt wget --recursive --tries 3 --level=1 --force-directories -P downloaded_crls/ --input-file=all_crls.csv  
</code></pre>

<p>This took 2h 36m 31s on my Internet connection.</p>

<h2 id="analyzingthedownloadprocess">Analyzing the Download Process</h2>

<p>Out of 3,035 CRLs, I ended up downloading 2,993 files. The rest failed.</p>

<p>I post-processed the command line <code>wget</code> <a href="https://gist.github.com/jcjones/92fe0297f950ba2748454b5ee8021b5b#file-crl_resolutions-csv">log (<code>wget_log-all_crls.txt</code>)</a> using a <a href="https://gist.github.com/jcjones/92fe0297f950ba2748454b5ee8021b5b#file-wget_log_processor-py">small Python script</a> to categorize each CRL download by how it completed.</p>

<p>Ignoring all the times when requesting a file resulted in the file straightaway (hey, those cases are boring), here's the graphical breakdown of the other cases:</p>

<p><img src="/content/images/2017/08/Screen-Shot-2017-08-17-at-4.03.40-PM.png" class="img-responsive" alt="Problems with CRL Downloads"></p>

<h3 id="missingcrls">Missing CRLs</h3>

<p>There are 40 CRLs that weren't available to me when I checked, or more simply put, 1% of CRLs appear to be dead.</p>

<p>Some of them are dead in temporary-looking ways, like the load balancer giving a <code>500 Internal Server Error</code>, some of them have hostnames that aren't resolving in DNS. </p>

<p>These aren't currently resolving for me:</p>

<ul>
<li><a href="http://www.cert.fnmt.es.testa.eu/crls/ARLFNMTRCMEU.crl"><code>http://www.cert.fnmt.es.testa.eu/crls/ARLFNMTRCMEU.crl</code></a> [<a href="https://censys.io/certificates?q=parsed.extensions.crl_distribution_points+%3D+%22http%3A%2F%2Fwww.cert.fnmt.es.testa.eu%2Fcrls%2FARLFNMTRCMEU.crl%22">Censys.io Search</a>]</li>
<li><a href="http://crl.testa.eu/"><code>http://crl.testa.eu/</code></a> [<a href="https://censys.io/certificates?q=parsed.extensions.crl_distribution_points+%3D+%22http%3A%2F%2Fcrl.testa.eu%2F%22">Censys.io Search</a>]</li>
<li><a href="http://grcl2.crl.telesec.de/rl/T-TeleSec_GlobalRoot_Class_2.crl"><code>http://grcl2.crl.telesec.de/rl/T-TeleSec_GlobalRoot_Class_2.crl</code></a> [<a href="https://censys.io/certificates?q=parsed.extensions.crl_distribution_points+%3D+%22http%3A%2F%2Fgrcl2.crl.telesec.de%2Frl%2FT-TeleSec_GlobalRoot_Class_2.crl%22">Censys.io Search</a>]</li>
<li><a href="http://cr.wscrl.cn/ca2.crl"><code>http://cr.wscrl.cn/ca2.crl</code></a> [<a href="https://censys.io/certificates?q=parsed.extensions.crl_distribution_points+%3D+%22http%3A%2F%2Fcr.wscrl.cn%2Fca2.crl%22">Censys.io Search</a>]</li>
<li><a href="http://www.ws.symantec.com/pca3-g3.crl"><code>http://www.ws.symantec.com/pca3-g3.crl</code></a> [<a href="https://censys.io/certificates?q=parsed.extensions.crl_distribution_points+%3D+%22http%3A%2F%2Fwww.ws.symantec.com%2Fpca3-g3.crl%22">Censys.io Search</a>]</li>
<li><a href="http://crl.sca0a.amazontrust.com/sca0a.crl"><code>http://crl.sca0a.amazontrust.com/sca0a.crl</code></a> [<a href="https://censys.io/certificates?q=parsed.extensions.crl_distribution_points+%3D+%22http%3A%2F%2Fcrl.sca0a.amazontrust.com%2Fsca0a.crl%22">Censys.io Search</a>]</li>
<li><a href="http://atospki/crl/Atos_TrustedRoot_CA_2011.crl"><code>http://atospki/crl/Atos_TrustedRoot_CA_2011.crl</code></a> [<a href="https://censys.io/certificates?q=parsed.extensions.crl_distribution_points+%3D+%22http%3A%2F%2Fatospki%2Fcrl%2FAtos_TrustedRoot_CA_2011.crl%22">Censys.io Search</a>]</li>
</ul>

<p>Searching Censys' dataset, these CRLs are only used by intermediate CAs, so presumably if one of the handful of CA certificates covered would need to be revoked, their IT staff could fix these links.</p>

<p>Except for <code>http://atospki/</code>, which is clearly an internal name. Mistakes like that can only be revoked via technologies like <a href="https://blog.mozilla.org/security/2015/03/03/revoking-intermediate-certificates-introducing-onecrl/">OneCRL</a> and CRLSets.</p>

<p>The complete list of 400s, 404s, and timeouts by URL is available in <a href="https://gist.github.com/jcjones/92fe0297f950ba2748454b5ee8021b5b#file-crl_resolutions-csv">crl_resolutions.csv</a>.</p>

<h4 id="arethemissingcrlsaproblem">Are the missing CRLs a problem?</h4>

<p>This doesn't attempt to eliminate possible false-positives where the CRL was for a certificate which is revoked by its parent. For example, if there is a chain <code>Root</code> -> <code>A</code> -> <code>B</code> -> <code>C</code>, and <code>A</code> is revoked, it may not be important that <code>A</code>'s CRL exist. (Thanks, <a href="https://twitter.com/sleevi_/">@sleevi</a> for pointing this out!)</p>

<h3 id="redirects">Redirects</h3>

<p>As could be expected, there were a fair number of CRLs which are now serviced by redirects. Interestingly, while section 7.1.2.2(b) of the Baseline Requirements require CRLs to have a "HTTP URL", 13 of the CRL fetches redirect to HTTPS, two of them through HSTS headers <sup>[1]</sup>. </p>

<p>There was a <a href="https://groups.google.com/d/msg/mozilla.dev.security.policy/jSHuE-Oc7rY/660iCGPZBgAJ">recent thread on Mozilla.dev.security.policy about OCSP responders that were only available over HTTPS</a>; these are problematic as OCSP and CRLs are used to decide whether a secure connection is possible. Having to make such a determination for the revocation check leads to a potential deadlock, so most software will refuse to try it.</p>

<p>Interestingly, there's one CRL that is encoded as HTTPS directly in certificates: <code>https://crl.firmaprofesional.com/fproot.crl</code> [<a href="https://censys.io/certificates?q=parsed.extensions.crl_distribution_points+%3D+%22https%3A%2F%2Fcrl.firmaprofesional.com%2Ffproot.crl%22">Censys.io search</a>][<a href="https://crt.sh/?q=870ed91b908c831672003003d451d2eccc13721531129a12f19a4266ce66f935">Example at crt.sh</a>] That's pretty clearly a violation of the Baseline Requirements.</p>

<h3 id="sizes">Sizes</h3>

<p>I've generally understood that most CRLs are small, but some are very large, so I expected some kind of bi-modal distribution. It's really not, though the retrieved CRLs do have a wild size distribution:</p>

<p><img src="/content/images/2017/08/Screen-Shot-2017-08-17-at-5.50.13-PM.png" alt="Size Distribution of CRLs" class="img-responsive"></p>

<p>In table form <sup>[2]</sup>:</p>

<table>  
<tr><th>Size Buckets</th><th># of CRLs</th></tr>  
<tr><td>0.5 KB</td><td>174</td></tr>  
<tr><td>0.5 KB to 0.625 KB</td><td>264</td></tr>  
<tr><td>0.625 KB to 0.75 KB</td><td>246</td></tr>  
<tr><td>0.75 KB to 1 KB</td><td>310</td></tr>  
<tr><td>1 KB to 2 KB</td><td>366</td></tr>  
<tr><td>2 KB to 4 KB</td><td>237</td></tr>  
<tr><td>4 KB to 8 KB</td><td>232</td></tr>  
<tr><td>8 KB to 32 KB</td><td>500</td></tr>  
<tr><td>32 KB to 64 KB</td><td>297</td></tr>  
<tr><td>64 KB to 128 KB</td><td>218</td></tr>  
<tr><td>128 KB to 1 MB</td><td>106</td></tr>  
<tr><td>1 MB to 8 MB</td><td>33</td></tr>  
<tr><td>8 MB to 128 MB</td><td>9</td></tr>  
</table>

<p>I figured that most CRLs would be tiny, and we'd have a handful of outliers. Indeed, 50% of the CRLs are less than 4 Kbytes, and 75% are less than 32 Kbytes: <br />
<img src="/content/images/2017/08/Screen-Shot-2017-08-17-at-6.06.52-PM.png" alt="Cumulative Distribution of CRL size" class="img-responsive"></p>

<p>On the top end, however, are 9 CRLs larger than 8 MB:  </p>

<table>  
<tr><th>URL</th><th>Size</th></tr>  
<tr><td><a href="http://www.sk.ee/repository/crls/esteid2011.crl">http://www.sk.ee/repository/crls/esteid2011.crl</a></td><td>66.57 MB</td></tr>  
<tr><td><a href="http://crl.godaddy.com/repository/mastergodaddy2issuing.crl">http://crl.godaddy.com/repository/mastergodaddy2issuing.crl</a></td><td>36.22 MB</td></tr>  
<tr><td><a href="http://crl.eid.belgium.be/eidc201208.crl">http://crl.eid.belgium.be/eidc201208.crl</a></td><td>16.03 MB</td></tr>  
<tr><td><a href="http://crl.eid.belgium.be/eidc201204.crl">http://crl.eid.belgium.be/eidc201204.crl</a></td><td>10.84 MB</td></tr>  
<tr><td><a href="http://crl.eid.belgium.be/eidc201207.crl">http://crl.eid.belgium.be/eidc201207.crl</a></td><td>10.82 MB</td></tr>  
<tr><td><a href="http://crl.eid.belgium.be/eidc201202.crl">http://crl.eid.belgium.be/eidc201202.crl</a></td><td>10.67 MB</td></tr>  
<tr><td><a href="http://crl.eid.belgium.be/eidc201203.crl">http://crl.eid.belgium.be/eidc201203.crl</a></td><td>10.66 MB</td></tr>  
<tr><td><a href="http://crl.eid.belgium.be/eidc201201.crl">http://crl.eid.belgium.be/eidc201201.crl</a></td><td>10.47 MB</td></tr>  
</table>

<p>Remember, these are part of the WebPKI, not some private hierarchy. For a convenient example of why browsers don't download CRLs when connecting somewhere, just point to these. </p>

<h3 id="downloadlatency">Download Latency</h3>

<p>Latency matters. I'm on a pretty fast Internet connection, but even so, some of the CRLs that were even reasonable sizes took a while to download. I won't harp on this, but just a quick histogram:</p>

<p><img src="/content/images/2017/08/Screen-Shot-2017-08-18-at-2.23.31-PM.png" alt="Histogram of CRLs bucketed by download time" class="img-responsive"></p>

<p>CRLs that took longer than 1 second to download on a really fast Internet connection -- 142 of them, or 4.7% -- are clear reasons for users' software to not check them for live revocation status.</p>

<h3 id="conclusionssuchasthereareany">Conclusions (such as there are any)</h3>

<p>CRLs are not an exciting technology, but they're still used by the Web PKI. Since they're not exciting, it appears that don't even need to keep your CRLs online; I mean, who checks these things, anyway?</p>

<p>Oh, yeah, me...</p>

<p>Still, with technologies such as CRLSets depending on CRLs as a means for revocation data, they clearly still have a purpose. It's not particularly convenient to make a habit of crawling OCSP responders to figure out the state of revocations on the Web.</p>

<h5 id="footnotes">Footnotes</h5>

<p><sup>[1]</sup> Note, that's not found by the <a href="https://gist.github.com/jcjones/92fe0297f950ba2748454b5ee8021b5b#file-wget_log_processor-py">Python script</a> ; you'll need to <code>grep</code> the log for <code>"URL transformed to HTTPS due to an HSTS policy"</code></p>

<p><sup>[2]</sup> I admit that the buckets are a bit arbitrary, but here's what it looks like without some manual massaging: <br />
<img src="/content/images/2017/08/Screen-Shot-2017-08-17-at-6.18.10-PM.png" alt="Auto-generated buckets" class="img-responsive"></p> 
					</div>
				</article>
				
				<!--- Sharing Section --->
				<!--- SHARING SECTION --->
<div class="post-share">
	<i class="share-button fa fa-share fa-2x"></i>
	<a titie="Share on Facebook" target="_blank" href="http://www.facebook.com/sharer.php?u=https://tacticalsecret.com/the-state-of-crls/"> <div class="share-button"><i class="fa fa-facebook-square fa-2x"></i></div></a>
	<a title="Share on Twitter" target="_blank" href="http://twitter.com/share?text=The State of CRLs Today&amp;url=https://tacticalsecret.com/the-state-of-crls/"> <div class="share-button"><i class="fa fa-twitter-square fa-2x"></i></div></a>
	<a title="Share on Google Plus" target="_blank" href="https://plus.google.com/share?url=https://tacticalsecret.com/the-state-of-crls/"> <div class="share-button"><i class="fa fa-google-plus-square fa-2x"></i></div></a>
</div>

				<!--- Comment sections - using DISQUS as default --->
								
			</div>
		</main>
		<footer>
			<!--- FOOTER SECTION  ---> 
<!--- Appear at the bottom of every page ---> 
<div class="footer">
</div>
		</footer>
	</div>
</div>


</body>

<script src="/assets/js/libs/prism.js?v=e1bc17359f"></script>

</html>
